Upgrade/Update PHP 5.1 ke 5.3 di linux centos

Kali ini penulis ingin berbagi ilmu hasil tanya-tanya ke paman google,sesuai dengan judulnya di atas ikuti langkah berikut untuk Upgrade/Update PHP 5.1 ke 5.3 di linux centos.

1.Cek versi php yang sudah terinstall dengan cara,
[root@server ~]# php -v
PHP 5.1.6 (cli) (built: Jan 18 2012 14:14:23)

Keterangan:
 PHP 5.1.6 (cli) (built: Jan 18 2012 14:14:23) yang artinya sudah terinstall php versi 5.1.6.

2.Cek paket-paket yang di butuhkan untuk Upgrade/Update PHP 5.1 ke 5.3 dengan cara,
[root@server ~]# yum search php53 | cut -d' ' -f1 | grep php
php53.x86_64
php53-bcmath.x86_64
php53-cli.x86_64
php53-common.x86_64
php53-dba.x86_64
php53-devel.x86_64
php53-gd.x86_64
php53-imap.x86_64
php53-intl.x86_64
php53-ldap.x86_64
php53-mbstring.x86_64
php53-mysql.x86_64
php53-odbc.x86_64
php53-pdo.x86_64
php53-pgsql.x86_64
php53-process.x86_64
php53-pspell.x86_64
php53-snmp.x86_64
php53-soap.x86_64
php53-xml.x86_64
php53-xmlrpc.x86_64
[root@server ~]#



Catatan:
Di atas adalah paket-paket yang di butuhkan untuk Upgrade/Update PHP 5.1 ke 5.3.

3.Matikan terlebihdahulu httpdnya,
[root@server ~]# service httpd stop
Stopping httpd: [ OK ]
[root@server ~]#

4.Hapus paket php yang sudah terinstall,
[root@server ~]# sudo yum remove php php-cli php-common php-devel php-gd php-mbs tring \
> php-mysql php-mcrypt php-pdo php-pear php-pgsql php-xml php-xmlrpc
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: php-devel
Loading mirror speeds from cached hostfile
Package(s) php-devel available, but not installed.
No Match for argument: php-gd
Package(s) php-gd available, but not installed.
No Match for argument: php-mbstring
Package(s) php-mbstring available, but not installed.
No Match for argument: php-mysql
Package(s) php-mysql available, but not installed.
No Match for argument: php-mcrypt
Package(s) php-mcrypt available, but not installed.
.......
Remove 3 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : php-cli 1/3
Erasing : php-common 2/3
Erasing : php 3/3

Removed:
php.x86_64 0:5.1.6-27.el5_7.4 php-cli.x86_64 0:5.1.6-27.el5_7.4 php-common.x86_64 0:5.1.6-27.el5_7.4

Complete!
[root@server ~]#

5.Install paket-paket berikut,
[root@server ~]# sudo yum install php53 php53-cli php53-common php53-devel php53 -gd \
> php53-mbstring php53-mysql php53-pdo php53-pgsql php53-xml php53-xmlrpc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53.x86_64 0:5.3.3-1.el5_7.5 set to be updated
---> Package php53-cli.x86_64 0:5.3.3-1.el5_7.5 set to be updated
---> Package php53-common.x86_64 0:5.3.3-1.el5_7.5 set to be updated
---> Package php53-devel.x86_64 0:5.3.3-1.el5_7.5 set to be updated
--> Processing Dependency: autoconf for package: php53-devel
--> Processing Dependency: automake for package: php53-devel
---> Package php53-gd.x86_64 0:5.3.3-1.el5_7.5 set to be updated
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: php53-gd
--> Processing Dependency: libpng12.so.0()(64bit) for package: php53-gd

Sampai muncul

Installed:
php53.x86_64 0:5.3.3-1.el5_7.5 php53-cli.x86_64 0:5.3.3-1.el5_7.5 php53-common.x86_64 0:5.3.3-1.el5_7.5 php53-devel.x86_64 0:5.3.3-1.el5_7.5
php53-gd.x86_64 0:5.3.3-1.el5_7.5 php53-mbstring.x86_64 0:5.3.3-1.el5_7.5 php53-mysql.x86_64 0:5.3.3-1.el5_7.5 php53-pdo.x86_64 0:5.3.3-1.el5_7.5
php53-pgsql.x86_64 0:5.3.3-1.el5_7.5 php53-xml.x86_64 0:5.3.3-1.el5_7.5 php53-xmlrpc.x86_64 0:5.3.3-1.el5_7.5

Dependency Installed:
autoconf.noarch 0:2.59-12 automake.noarch 0:1.9.6-2.3.el5 freetype.x86_64 0:2.2.1-28.el5_7.2 imake.x86_64 0:1.0.2-3
libX11.x86_64 0:1.0.3-11.el5_7.1 libXau.x86_64 0:1.0.1-3.1 libXdmcp.x86_64 0:1.0.1-2.1 libXpm.x86_64 0:3.5.5-3
libgcrypt.x86_64 0:1.4.4-5.el5 libgpg-error.x86_64 0:1.4-2 libjpeg.x86_64 0:6b-37 libpng.x86_64 2:1.2.10-7.1.el5_7.5
libxslt.x86_64 0:1.1.17-2.el5_2.2 m4.x86_64 0:1.4.5-3.el5.1 mysql.x86_64 0:5.0.77-4.el5_6.6 perl-DBI.x86_64 0:1.52-2.el5
xorg-x11-filesystem.noarch 0:7.1-2.fc6

Complete!
[root@server ~]#

6.Cek versi php yang sudah terinstall,
[root@server ~]# php -v
PHP 5.3.3 (cli) (built: Jan 11 2012 13:54:48)

7.Sekarang hidupkan kembali httpdnya,
[root@server ~]# service httpd start
Starting httpd: [ OK ]
[root@server ~]#

Selamat versi php pembaca sudah terupdate ! ! !

Kirim Artikel

Related Posts

Previous
Next Post »